通達信倉位控制的量化標準指標公式

DRAWTEXT_FIX(1,0.01,0.01,0,"【★★倉位控制的量化標準★★】"),COLORMAGENTA;

DRAWTEXT_FIX(1,0.01,0.08,0,"【★★1、粉+紅=滿,2、粉+綠=6,3、藍+紅=4 ,4、藍+綠=空★★】"),COLORYELLOW;

E1:=EXPMA(C,5);

E2:=EXPMA(C,10);

E3:=EXPMA(C,20);

E4:=EXPMA(C,30);

E5:=EXPMA(C,60);

VARE1:=(E1+E2+E3+E4)/4;

VARE2:=(E1+E2+E3+E5)/4;

N:=IF(CODELIKE("9999")OR CODELIKE("3990")OR CODELIKE("880")OR CODELIKE("0000"),1,0);

D1:=IF(N=1,0.013,0.03);

D2:=IF(N=1,0.018,0.03);

C1:=IF(N=1,0.015,0.03);

C2:=IF(N=1,0.015,0.03);

短線多:EXPMA(VARE1,5)+EXPMA(VARE1,5)*D1,COLORRED;

短線空:EXPMA(VARE1,5)-EXPMA(VARE1,5)*D2,COLORRED;

長線多:EXPMA(VARE2,70)+EXPMA(VARE2,70)*C1,COLORMAGENTA;

長線空:EXPMA(VARE2,70)-EXPMA(VARE2,70)*C2,COLORMAGENTA;

{官方網址:WWW.HONGHAIE.COM}

TJ1:=RANGE(C,短線空,短線多);

TJ2:=RANGE(C,長線空,長線多);

STICKLINE(短線多>REF(短線多,1) AND TJ1=0,短線多,短線空,0.1,1),COLORRED;

STICKLINE(短線多<REF(短線多,1) AND TJ1=0,短線多,短線空,0.1,1),COLORGREEN;

STICKLINE(長線多>REF(長線多,1) AND TJ2=0,長線多,長線空,0.1,1),COLORMAGENTA;

STICKLINE(長線多<REF(長線多,1) AND TJ2=0,長線多,長線空,0.1,1),COLORBLUE;

NOTEXT短線多:IF(短線多<REF(短線多,1),短線多,DRAWNULL),COLORGREEN;

NOTEXT短線空:IF(短線空<REF(短線空,1),短線空,DRAWNULL),COLORGREEN;

NOTEXT長線多:IF(長線多<REF(長線多,1),長線多,DRAWNULL),COLORBLUE;

NOTEXT長線空:IF(長線空<REF(長線空,1),長線空,DRAWNULL),COLORBLUE;

空:=REF(C,1)>REF(短線空,1) AND C<短線空 AND C<REF(C,1){ AND COUNT(C>短線多,5)>0};

多:=REF(C,1)<REF(短線多,1) AND C>短線多 AND C>REF(C,1){ AND COUNT(C<長線多,5)>0};

空1:=TFILTER(多,空,2);

多1:=TFILTER(多,空,1);

DRAWTEXT(空1,短線多*1.04,"空"),COLORGREEN;

DRAWTEXT(多1,短線空*0.96,"多"),COLORRED;

DRAWICON(空1,短線多*1.02,2);

DRAWICON(多1,短線空*0.98,1);

A1:=C>REF(C,4);

A2:=BARSLASTCOUNT(A1);

A3:=REF(A2,1)=8 AND A2>REF(A2,1);

A4:=REF(BETWEEN(A2,5,8),1) AND A2<REF(A2,1);

A5:=ISLASTBAR AND BETWEEN(A2,6,8);

A6:=(BACKSET(A3>0,9) OR BACKSET(A4>0,A2+1)*0 OR BACKSET(A5>0,A2))*A2;

DRAWTEXT(A6>0,H+H*0.02,VAR2STR(A6,0)),COLORFF00FF{COLOR00FFFF};

DRAWTEXT(A2=9,H+H*0.02,"9"),COLOR00FF00;

B1:=C<REF(C,4);

B2:=BARSLASTCOUNT(B1);

B3:=REF(B2,1)=8 AND B2>REF(B2,1);

B4:=REF(BETWEEN(B2,5,8),1) AND B2<REF(B2,1);

B5:=ISLASTBAR AND BETWEEN(B2,6,8);

B6:=(BACKSET(B3>0,9) OR BACKSET(B4>0,B2+1)*0 OR BACKSET(B5>0,B2))*B2;

DRAWTEXT(B6>0,L-L*0.02,VAR2STR(B6,0)),COLOR00FF00{COLORFFFFFF};

DRAWTEXT(B2=9,L-L*0.02,"9"),COLORFF00FF;

免責聲明:本文僅代表文章作者的個人觀點,與本站無關。其原創性、真實性以及文中陳述文字和內容未經本站證實,對本文以及其中全部或者部分內容文字的真實性、完整性和原創性本站不作任何保證或承諾,請讀者僅作參考,并自行核實相關內容。

http://www.uswqb.club/style/images/nopic.gif
分享
評論
首頁
高速公路之王电子游艺
竞彩足球比分专家推荐 福彩18选7开奖查询 金蟾捕鱼的打鱼技巧 排列五直播新浪直播彩通 黑金快乐8登录网站 浙江6+1开奖结果查询18122 王牛王中奖结果网站 福彩3D试机号分析 新疆11选5前三直选遗漏 云南山水麻将安卓下载 遇乐棋牌大厅下载 10万元闲钱怎样理财好 乐游美人捕鱼游戏下载 新疆18选7玩法 海南麻将在线 韩国快乐8开奖官网