【大智慧】依據黑馬王子的《量柱擒漲停》而編的王子量柱指標(源碼 主圖 貼圖)

依據黑馬王子的《量柱擒漲停》而編的王子量柱指標(源碼 主圖 貼圖)

來自:理想論壇(55188.com) 作者:甘寧波 瀏覽:67254次 終于找到這個指標了,非常感謝原創作者,本人借花獻佛了,好東西當然要分享。

本指標有未來函數,至于為什么要用未來函數,簡單的說就是需要用3日確定這種走勢,若需詳細知道為什么請看黑馬王子的書:

《量柱擒漲停》

論壇內有下載,自己去搜索吧。

需要懂他的理論才能用好。

大智慧第二代的源碼如下:

MA20:MA(C,20),ColorFF8888;

DRAWTEXTABS(5,10,"所屬板塊:"+BKNAME),ColorAFFF00;

DRAWTEXTABS(5,30,"每股收益:"+NUMTOSTRN(FINANCE2(3),3)+"元"+" 市盈率:"+NUMTOSTRN(DYNAINFO(39),2)+"元"+" 市凈率:"+NUMTOSTRN((CLOSE / FINANCE2(4)),2)+"元"+" 凈資產:"+NUMTOSTRN(FINANCE2(4),2)+"元"),Color00C0FF;

三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);

三日量縮:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));

三日價漲A:=C>=REF(C,1);

三日價漲B:=C<REF(C,1);

三日價漲C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);

縮倍柱:=(VOL*1.95<=REF(VOL,1));

百日低量:=(VOL=LLV(VOL,100));

倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1));

四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4));

四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量縮);

前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日價漲C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日價漲C,1)),3)=0;

倍量黃金柱:=四日前倍量柱 AND 三日量縮 AND 三日不破 AND 三日價漲A AND 前三引用不成立;

高量黃金柱:=四日前高量柱 AND 三日量縮 AND 三日不破 AND 三日價漲A AND 前三引用不成立;

黃金柱:=倍量黃金柱 OR 高量黃金柱;

次倍量黃金柱:=NOT(黃金柱) AND 四日前倍量柱 AND 三日量縮 AND 三日不破 AND 三日價漲B AND 前三引用不成立;

次高量黃金柱:=NOT(黃金柱) AND 四日前高量柱 AND 三日量縮 AND 三日不破 AND 三日價漲B AND 前三引用不成立;

次黃金柱:=次倍量黃金柱 OR 次高量黃金柱;

準倍量黃金柱:=NOT(黃金柱 OR 次黃金柱) AND 四日前倍量柱 AND ((三日量縮 AND 三日價漲C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;

準高量黃金柱:=NOT(黃金柱 OR 次黃金柱) AND 四日前高量柱 AND (三日量縮 AND 三日價漲C) AND 前三引用不成立;

準黃金柱:=準倍量黃金柱 OR 準高量黃金柱;

倍量將軍柱:=NOT(黃金柱 OR 次黃金柱 OR 準黃金柱) AND 四日前倍量柱 AND 三日不破 AND 三日價漲A AND 前三引用不成立;

高量將軍柱:=NOT(黃金柱 OR 次黃金柱 OR 準黃金柱) AND 四日前高量柱 AND 三日不破 AND 三日價漲A AND 前三引用不成立;

將軍柱:=倍量將軍柱 OR 高量將軍柱;

次倍量將軍柱:=NOT(黃金柱 OR 次黃金柱 OR 準黃金柱 OR 將軍柱) AND 四日前倍量柱 AND 三日不破 AND 三日價漲B AND 前三引用不成立;

次高量將軍柱:=NOT(黃金柱 OR 次黃金柱 OR 準黃金柱 OR 將軍柱) AND 四日前高量柱 AND 三日不破 AND 三日價漲B AND 前三引用不成立;

次將軍柱:=次倍量將軍柱 OR 次高量將軍柱;

準倍量將軍柱:=NOT(黃金柱 OR 次黃金柱 OR 準黃金柱 OR 將軍柱 OR 次將軍柱) AND 四日前倍量柱 AND 三日價漲C AND 前三引用不成立;

準高量將軍柱:=NOT(黃金柱 OR 次黃金柱 OR 準黃金柱 OR 將軍柱 OR 次將軍柱) AND 四日前高量柱 AND 三日價漲C AND 前三引用不成立;

準將軍柱:=準倍量將軍柱 OR 準高量將軍柱;

BACKSET100:=BACKSET(黃金柱 OR 次黃金柱 OR 準黃金柱 OR 將軍柱 OR 次將軍柱 OR 準將軍柱,4);

FILTER100:=FILTER(BACKSET100,3);

BACKSET101:=BACKSET(黃金柱,4);

FILTER101:=FILTER(BACKSET101,3);

BACKSET102:=BACKSET(次黃金柱,4);

FILTER102:=FILTER(BACKSET102,3);

BACKSET103:=BACKSET(準黃金柱,4);

FILTER103:=FILTER(BACKSET103,3);

BACKSET104:=BACKSET(將軍柱,4);

FILTER104:=FILTER(BACKSET104,3);

BACKSET105:=BACKSET(次將軍柱,4);

FILTER105:=FILTER(BACKSET105,3);

BACKSET106:=BACKSET(準將軍柱,4);

FILTER106:=FILTER(BACKSET106,3);

DRAWTEXT(FILTER101,LOW*0.986,"↖黃金柱"),COLOR0099FF;

STICKLINE(FILTER101,OPEN,CLOSE,6,0),COLOR0099FF;

DRAWTEXT(FILTER102,LOW*0.986,"↖次黃"),COLOR00EEFF;

STICKLINE(FILTER102,OPEN,CLOSE,6,0),COLOR00EEFF;

DRAWTEXT(FILTER103,LOW*0.986,"↖準黃"),COLOR00EE99;

STICKLINE(FILTER103,OPEN,CLOSE,6,0),COLOR00EE99;

DRAWTEXT(FILTER104,LOW*0.986,"↖將軍柱"),COLORRED;

STICKLINE(FILTER104,OPEN,CLOSE,6,0),COLORRED;

DRAWTEXT(FILTER105,LOW*0.986,"↖次將"),COLOR8822FF;

STICKLINE(FILTER105,OPEN,CLOSE,6,0),COLOR8822FF;

DRAWTEXT(FILTER106,LOW*0.986,"↖準將"),COLORDD22DD;

STICKLINE(FILTER106,OPEN,CLOSE,6,0),COLORDD22DD;

K1:=SUMBARS(FILTER104,1);

STICKLINE(K1,REF(L,K1-2),REF(L,K1-2),20,0),COLOR8822FF;

STICKLINE(K1,REF(L,K1-1),REF(L,K1-1),3,0),COLORGREEN;

K2:=SUMBARS(FILTER101,1);

STICKLINE(K2,REF(L,K2-2),REF(L,K2-2),20,0),COLOR0099FF;

立樁量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);

立樁量三日突破:=IF(BARSLAST(立樁量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立樁量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立樁量)=3 AND CLOSE>REF(HIGH,3),1,0)));

立樁量三日不破:=BARSLAST(立樁量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));

BACKSET300:=BACKSET(立樁量三日不破,4);

BACKSET301:=BACKSET(立樁量三日突破,4);

立樁量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立樁量;

DRAWTEXT(立樁量成立,HIGH*1.03,"←立柱"),COLORGREEN;

[ 本帖最后由 甘寧波 于 2011-3-12 12:18 編輯 ]股票論壇 www.55188.com

附件:

未命名.JPG (62.21 KB)

2011-3-9 12:26

免責聲明:本文僅代表文章作者的個人觀點,與本站無關。其原創性、真實性以及文中陳述文字和內容未經本站證實,對本文以及其中全部或者部分內容文字的真實性、完整性和原創性本站不作任何保證或承諾,請讀者僅作參考,并自行核實相關內容。

http://www.uswqb.club/style/images/nopic.gif
分享
評論
首頁
高速公路之王电子游艺
网赚app平台 陕西十一选五 球探体育比分app老版本 辽宁省11选5开奖结果 25选7开奖时间 能打东北麻将的软件 浙江快乐十二开奖公告 3d过滤缩水工具免费 甘肃快3开奖结果 平特一肖自创规律 比较好玩的棋牌游戏 快乐10分软件下载 福彩3d藏机图 北京期货配资 网赚app下载 天天棋牌客户端?